Mailman 2.1 installation requirements

As of this writing, Mailman 2.1.14 is not compatible with Python 2.1 or Python 2.2 and Mailman can no longer be validated against them. Also, the new Sibling Lists feature in Mailman 2.1.10 and up uses Python sets and thus is not compatible with Python 2.3 or older. Other incompatibilities between recent Mailman and some Python 2.4.x versions and Python 2.5 have been observed, and there is a rare issue with Mailman 2.1.22 through 2.1.25 and a more serious issue in Mailman 2.1.26 that requires Python 2.7. For Mailman 2.1.27 The minimum supported Python is 2.6. It is highly recommended that you upgrade to the latest patch release of Python 2.7

For now, we recommend using Python 2.7.15.

MailmanWiki: DOC/Installation requirements (last edited 2018-06-05 19:24:06 by msapiro)